Both zig and go use the dot operator, but I find the ‘::’ operator much more readable.
Vec::new();
Makes it clear that were accessing a static method belonging to the Vec struct/namespace.
Vec.new()
Makes it seem like Vec is an object with a ‘new’ method.
Am I alone in thinking this?
Anything is fine as long as it’s not an arrow (I’m looking at you, PHP)
Sweats nervously in C pointer
C is the cool grandpa of today’s programming languages so he can get away with this
Nobody would cry if it disappeared tomorrow though