Both zig and go use the dot operator, but I find the ‘::’ operator much more readable.
Vec::new();
Makes it clear that were accessing a static method belonging to the Vec struct/namespace.
Vec.new()
Makes it seem like Vec is an object with a ‘new’ method.
Am I alone in thinking this?
C++ was my language of choice for a long time, but I can’t say I’m with you on this one. If I’m going to use Vec, I had better know what it is already. Littering the code with a special double-glyph operator when a dot would do is just needless noise to me.
(I won’t criticize you for liking it, though. Cheers.)